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Chapter 1

MWM

1.1 MWM.guide/Contenuti

+--- - - - - ---+--- - - - ←↩
- ---+

| ! Benvenuto nel primo generatore di file HTML facile-da-usare! |

+--- - - - - ---+--- - - - - ---+

M W M

-->* Magic WWW (World-Wide Web) files Maker *<--
_______________________________________

|
|
|

Versione 3.11
___________________________________

| |
| from an idea of Maurizio Fabiani |
| developed by Massimo Baglione |
|___________________________________|

Di cosa si tratta ?

La finestra principale
-->
Tasti speciali

La finestra per la singola linea

La finestra di aiuto

La finestra ’’ What is ? ’’

Il menu

Cosa puo’ fare MWM ?



MWM 2 / 26

Informazioni generali

Ringraziamenti

Novita’ di MWM

Addendum

1.2 MWM.guide/Di cosa si tratta?

DI COSA SI TRATTA ?

Un giorno il mio amico Maurizio mi chiese: "Hey Max, pensi sia possibile
scrivere un programma per la creazione di file in formato HTML che dia la
possibilita’ all’ utente di caricare normali file ASCII e trasformarli in
HTML selezionando parti di testo utilizzando il mouse ?"

Gli feci capire che non ero in grado di operare miracoli, ma lui insistette.

Bene, ora ci sono quasi riuscito.

MWM infatti consente di caricare un normale file di testo e tramite il mouse
si puo’ applicare alle righe o alle singole parole selezionate le immagini, i
testi e tutto quello che consente il formato HTML.

L’ interfaccia grafica e’ composta essenzialmente da :

- Finestra principale, che mostrera’ il normale file di testo caricato.
Se al testo e’ stata applicata qualche particolare azione, allora verra’
evidenziato con un colore diverso dal resto del testo.
Come molti programmi grafici e word processor, questa finestra contiene
delle piccole immagini associate a delle azioni.

- Finestra per editare una singola linea di testo ed inserire piu’ di un
oggetto nella stessa riga.

- Finestra delle etichette, che mostrera’ le etichette contenute in un
file HTML da linkare. (vedere in seguito)

- Finestra di aiuto, che informa l’ utente su tutto cio’ che sta’
facendo o succedendo.
MWM mette a disposizione tre livelli di informazioni:

- None, ovvero nulla se non l’essenziale.
- Medium, descrizione sommaria dell’ oggetto selezionato.
- High, informazione dettagliata.

- Finestra "What is?", che associa ad ogni riga del testo una piccola
stringa per poter riconoscere "al volo" ogni oggetto.
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1.3 MWM.guide/La finestra principale

LA FINESTRA PRINCIPALE.

Una volta caricato il file di testo, lo si potra’ vedere chiaramente in una
delle finestre: la finestra principale.

Con il tasto sinistro del mouse si seleziona una porzione di testo e con
uno dei gadget degli strumenti gli si puo’ assegnare un’ azione che puo’
essere una immagine, un riferimento ad altro testo, una lista e tutte
quelle belle cosette che consente il formato HTML.

Se avete la necessita’ di applicare azioni a singole parole all’ interno di
una riga e’ sufficiente selezionare tale riga con un doppio click.

Una piccola finestra si aprira’ con l’intera riga del testo messa a vostra
disposizione: la finestra per la singola linea.

Il motivo per il quale non ho implementato tale possibilita’ direttamente nella
finestra principale e’ dovuto al fatto che ho voluto semplificare al massimo
l’ uso del programma e che comunque il tipo di gestione del testo di MWM
renderebbe troppo lenta la visualizzazione in caso di scroll.

Applicando diverse azioni al testo si creano degli oggetti che saranno
visualizzati con colori diversi per poterli distinguere con facilita’.

L’ oggetto viene numerato in base all’ ordine di creazione e selezionandolo
si avra’ la possibilita’ di controllarne i dati essenziali nella finestra di
aiuto.

Partendo dal primo gadget a sinistra troviamo:

TEXT

IMAGE

LIST

FORM

MORE

HEAD

CENTER

VIEW

PREFS

1.4 MWM.guide/Primo gadget TEXT
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TEXT gadget

Si intende definire per le linee selezionate un particolare tipo di
testo.

MWM aprira’ una finestra con diversi gadget:

- "Type" gadget:

- Plain; il testo selezionato rimarra’ tale nel file HTML finale..

- Link into this document;
E’ un link ad una etichetta gia’ creata all’ interno del
documento corrente.

- Link to another document;
In questo caso programmi tipo Mosaic evidenzieranno questa
parte di testo e, se l’ utente selezionera’ col mouse questa
porzione, allora verra’ chiamato il nuovo testo definito da
questa azione.

- Link to a site.
E’ un link ad un sito in cui si desidera entrare.

- Preformatted;
Programmi tipo Mosaic sono "obbligati" a formattare il testo
che devono visualizzare seguendo gli standard in vigore.
Con tale azione si intende specificare che tutto il testo
selezionato non dovra’ assolutamente essere influenzato da
tale formattazione.
E’ molto utile per quei testi che perderebbero di significato
se venisse modificata l’ impaginazione originale, ad esempio i
listati dei programmi.
Il testo selezionato sara’ racchiuso tra <PRE> e </PRE> e verra’
visualizzato con un font fixed width (typewriter) dal browser.

- Address.
Con questa azione MWM inserira’ le linee selezionate nell’ area
dedicata alle informazioni dell’ autore del documento, ovvero fara’
parte del <ADDRESS> del documento HTML.
Programmi tipo Mosaic evidenzieranno questo testo.

- Paragraph.
Il testo selezionato sara’ racchiuso tra <P> e </P>, ovvero faranno
parte di un paragrafo.
Il tipo di allineamento possibile e’:

DEFAULT, LEFT, CENTER, RIGHT, JUSTIFY.

- "Link" gadget:

Attivo per "link to another document", permette di scegliere il file
che dovra’ essere linkato.

- "Label" gadget:
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Attivo per "link into this document" e "link to another document",
permette di scegliere la label (etichetta) nel file selezionato che
dovra’ essere linkata.

- "URI" gadget:

Attivo per "link to a site";
MWM vi dara’ i seguenti tipi di URI:

file://localhost/
http://
ftp://
mailto:
news:
gopher:
telnet:

- "Site" gadget:

Attivo per "link to a site";
MWM aprira’ un requester per sapere dove dovra’ prendere il nome del
sito. Si puo’ decidere tra:

- Selected line
Il nome del sito e’ rappresentato dalla prima linea selezionata.
Se le linee selezionate sono piu’ di una, allora MWM le ridurra’
automaticamente a una e prendera’ da essa il nome del sito.

- Keyboard
Il nome del sito dovra’ essere inserito manualmente.

- PATH:file
Il nome del sito e’ definito in un file apposito.
E’ necessario definire una lista di siti prima di usare MWM.
La lista DEVE essere simile a questa:

www.vol.it
agnus.livewire.com
www.lycos.com
www.yahoo.com
...

Se non diversamente specificato, MWM cerchera’ la lista dei
siti nel file "PROGDIR:MWM.sites".
E’ possibile specificare una diversa locazione del suddetto
file usando la funzione del gadget "PREFS" alla voce
"Sites list".

- "Markup" gadget:

Aggiunge un Markup al testo corrente.
Si puo’ scegliere fra:

- Citation (Typically in italic). (CITE)
- Emphasis (EM)
- Strong emphasis (STRONG)
- Code (CODE)
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Looks like preformatted text,
for example: 1 + 1 = 2.

- Author (AU)
For an author of a book, etc.

- Person (PERSON)
For a generic person name.

- Sequence of chars. (SAMP)
- Keyboarded text. (KBD)
- Variable name. (VAR)
- Definition. (DFN)
- Short quote. (Q)
- Acronyms. (ACRONYM)
- Abbreviations. (ABBREV)
- Inserted text. (INS)
- Deleted text. (DEL)
- Bold text. (B)
- Italic text. (I)
- Typewriter text. (TT)
- Underscored text. (U)
- "Lined" text. (S)
- Big text. (BIG)
- Small text. (SMALL)
- Subscripted (SUB)
- Superscripted (SUP)
- Nothing (to clear current markup)

- "Font" gadget:

Con questa funzione e’ possibile cambiare le dimensioni del font per
il testo attualmente selezionato.

Le possibilita’ sono:

- <H1> Font larghissimo, in neretto.
- <H2> Font largo, in neretto.
- <H3> Font largo, in corsivo.
- <H4> Font normale, in neretto.
- <H5> Font normale, in corsivo.
- <H6> Font piccolo.

C’e’ da dire che queste definizioni sono solo un’ indicazione, dipende
da come il browser e il suo sistema e’ settato, percui il testo puo’
apparire diverso in ciascun sistema.

Per default, MWM imposta a 5 (H5) tale valore che puo’ essere
modificato selezionando il gadget "PREFS" alla voce "HTML defaults".

- "Align" gadget:

Questo gadget e’ usato per specificare l’allineamento per l’heading.

- Left;
- Center;
- Right;
- Justify;

- "OK" gadget:
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Conferma l’azione e inserisce l’oggetto nel buffer.

- "Cancel" gadget:

Chiude la finestra senza modifiche..

- "Delete" gadget:

Permette di cancellare l’oggetto che si sta editando..

Se si rende necessario ritoccare un oggetto di tipo TESTO, e’ sufficiente
clickare sul gadget "TEXT" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.5 MWM.guide/Secondo gadget IMAGE

IMAGE gadget

Con questa azione si intende _SOSTITUIRE_ il testo selezionato con una
immagine.

MWM aprira’ una finestra con i seguenti gadget:

- "Choose" gadget:

Un requester vi permettera’ di selezionare l’immagine desiderata.

- "Alt" gadget:

Qui e’ possibile definire il testo alternativo (ALT) per la
immagine selezionata.

- "Type" gadget:

Con questo gadget si definisce il tipo di immagine:

- Simple; semplice.
- Map; di tipo mappa.
- Link to current; (vedere TEXT Gadget, dietro)
- Link to another; (vedere TEXT Gadget, dietro)
- Link to a site; (vedere TEXT Gadget, dietro)

- "Align" gadget:

Qui si puo’ definire l’allineamneto dell’immagine con l’eventuale
testo:

- TOP
- MIDDLE
- BOTTOM

- "Link" gadget: (vedere TEXT Gadget, dietro)
- "Label" gadget: (vedere TEXT Gadget, dietro)
- "URI" gadget: (vedere TEXT Gadget, dietro)
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- "Site" gadget: (vedere TEXT Gadget, dietro)
- "OK" gadget: (vedere TEXT Gadget, dietro)
- "Cancel" gadget: (vedere TEXT Gadget, dietro)
- "Delete" gadget: (vedere TEXT Gadget, dietro)

Se si rende necessario ritoccare un oggetto di tipo IMMAGINE, e’
sufficiente clickare sul gadget "IMAGE" quando il suddetto oggetto e’
selezionato (oppure un doppio click con il tasto sinistro del mouse
su di esso).

1.6 MWM.guide/Terzo gadget LIST

LIST gadget

Questa azione vi permette di trasformare il testo selezionato in una lista.

MWM aprira’ una finestra con i seguenti gadget:

- "Type" gadget:

- Semplice (unnumbered), del tipo:

* fa caldo

* fa freddo

* piove

Per la lista non numerata e’ possibile anche definire il tipo di
bullet come disc, circle oppure square.

- Numerata (numbered), del tipo:

1- Non bere se devi guidare
2- Non guidare se hai bevuto
3- Il cappuccino e’ piu’ buono della birra
4- Il latte e’ finito, datemi una birra!

Per la lista numerata e’ possibile definire il tipo di numerazione
che puo’ essere del tipo roman, alphanumeric oppure arabic.

- Definita (definition), del tipo:

Colori

rosso
verde
blu

Planetario

Mercurio
Marte
Terra
Giove
...
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- "Add image" e "Add text" gadgets:

Questa azione permette di applicare un oggetto di tipo "TESTO"
o di tipo "IMMAGINE" all’ elemento della lista visualizzato nel gadget
in basso.

- "Compact" gadget:

Se attivo, permette di stabilire che il browser deve visualizzare
la lista in modo compatto <UL COMPACT>.

- "Plain" gadget:

Se attivo, permette di stabilire che il browser deve visualizzare
la lista ’unnumbered’ senza i classici pallini <UL PLAIN>.

- "Continue" gadget:

Stabilisce che la lista numerata deve continuare con la numerazione a
partire dalla fine della precedente <OL CONTINUE>.

- "Starting from (START)" gadget:

Imposta il numero con il quale la lista numerata deve cominciare la
numerazione <OL START=n>.
Usabile solo se il gadget "Continue" non e’ selezionato.

- "<LH> Header" gadget:

Usato per definire il titolo della lista.

- "Bullet/Number"" gadget:

Per la lista non numerata e’ possibile definire il tipo di bullet come
disc, circle oppure square.

Per la lista numerata e’ possibile definire il tipo di numerazione che
puo’ essere del tipo roman, alphanumeric oppure arabic.

Questo e’ un esempio di una lista numerata con una numerazione del
tipo "roman":

<OL TYPE="I">
<LI> First...
<LI> Second...
<LI> Third...
<LI> Some other things...

</OL>

questa verra’ visualizzata dal browser piu’ o meno nel modo seguente:

I First...
II Second...

III Third...
IV Some other things...

- "Prev" e "Next" gadgets:
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Questi due gadget permettono di muoversi linea per line all’interno
della lista per potervi applicare un testo o una immagine.

- "OK" gadget: (vedere TEXT Gadget, dietro)
- "Cancel" gadget: (vedere TEXT Gadget, dietro)

- "Delete" gadget:

Permette di cancellare la lista attualmente editata.
Se la lista contiene oggetti di tipo testo o immagine un requester
chiedera’ se si desidera cancellare solo la lista lasciando inalterati
i suddetti oggetti, o cancellare tutto.

Se si rende necessario ritoccare un oggetto di tipo LISTA, e’ sufficiente
clickare sul gadget "LIST" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.7 MWM.guide/Quarto gadget FORM

FORM gadget

Questa azione e’ composta da due passi:

nel primo si dovra’ definire la parte di testo che fara’ parte del form.
MWM aprira’ una finestra con i seguenti gadget:

- "Method" gadget:

- GET
- POST

- "Action" gadget:

Con questo gadget si puo’ specificare l’ azione (ACTION) del form, che
e’ una specifica URL. L’ azione sara’ del tipo: "http://x/y/sample".

Dopo questo primo passo noterete che il testo cambia colore ma e’ ancora
possibile (a differenza di tutti gli altri tipi di oggetti) selezionare una
o piu’ linee all’ interno del blocco del form.

Nel secondo passo sara’ possibile definire i vari componenti del form.
La stessa azione fara’ aprire a MWM una finestra con i seguenti gadget:

- "Type" gadget:

- Plain text; e’ un semplice testo
Il testo selezionato sara’ interpretato come un semplice testo,
utile per inserire descrizioni agli oggetti piu’ importanti.

- INPUT;

- List of INPUTs; e’ una lista di INPUT:
Non funzionante se si sta lavorando con la finestra per la
singola linea.



MWM 11 / 26

Tutti gli INPUT da definire saranno inclusi in una lista.

- "Input" gadget:

Questo gadget contiene i seguenti tipi di INPUT:

Text, Password, Checkbox, Radio, Range, Scribble,
File, Hidden, Submit, Image, Reset e Textarea.

Scegliendo il numero 4 (RADIO), MWM controllera’ se il gadget
"Same RADIO group" e’ selezionato o meno.
Se lo e’, allora il gruppo di INPUT del tipo RADIO che
si stanno creando avranno lo stesso campo e quindi, una volta creato
il file HTML, Mosaic (o chi per lui) costruira’ i gadget di tipo
RADIO accertandosi che uno e solo uno possa essere selezionato dallo
user.

- "Name" gadget:

Con questo si puo’ specificare il campo NAME di un INPUT.

- "Value" gadget:

COn questo si specifica il valore di default, o quello iniziale, del
campo VALUE di un INPUT.

- "Width" e "Max" gadgets:

Con questi gadget si definiscono la dimensione in caratteri e il
massimo numero di caratteri permessi per gli input di tipo TEXT e
PASSWORD.

- "From", "To", "Value" gadgets:

Se si sta creando un input di tipo RANGE, tutti questi tre gadget
saranno abilitati per definire i rispettivi campi dell’ input.

- "Rows" e "Cols" gadgets:

Con questi gadget le dimensioni in caratteri per l’elemento TEXTAREA

- "Accept" gadget:

Usato per definire il campo ACCEPT dell’ input di tipo FILE.

- "Source" gadget:

Usato per definire il campo SRC per tutti gli input che lo richiedano.

- "Next" e "prev" gadgets:

Disattivati se il gadget "Same Radio group" non e’ selezionato.
Altrimenti utili per definire i campi VALUE e SELECTED per ogni
elemento del gruppo di gadget del tipo RADIO.

- "OK" gadget: (vedere TEXT Gadget, dietro)
- "Cancel" gadget: (vedere TEXT Gadget, dietro)
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- "Delete" gadget: (vedere TEXT Gadget, dietro)

Ogni elemento del form (esclusi quelli inseriti in una lista) sara’ salvato
nel file HTML prefissato con la stringa <P> che serve a separare il testo
riga per riga.

Per inserire due o piu’ elementi del form nella stessa linea e’ possibile
fare un doppio click su una linea ed editarla con la finestra per la
singola linea.

Se si rende necessario ritoccare un oggetto di tipo FORM, e’ sufficiente
clickare sul gadget "FORM" quando il suddetto oggetto e’ selezionato.

1.8 MWM.guide/Quinto gadget MORE

MORE gadget

MWM considerera’ la prima linea selezionata chiedendo cosa
dovra’ farci. Le possibilita’ sono:

- Insert label here (<ID>) for hyperlinks;
- Insert comment here (<!-- -->);
- Insert empty line. (<P>)
- Insert horizontal graphic line (<HR>).

1.9 MWM.guide/Sesto gadget HEAD

HEAD gadget

Con questa azione si intende specificare che la parte di testo selezionata
e’ l’ HEAD (la testa) del file HTML.
MWM aprira’ una finestra con i seguenti gadget:

- "Title" gadget:

Usato per definire il titolo <TITLE> del documento.

- "Description" gadget:

Permette a MWM di inserire, ad esempio, la seguente linea:

<META NAME="description" CONTENT="We are the world!">

- "Choose" gadget:

Usato per definire un banner fisso:

<LINK REL=BANNER HREF="/Work:Docs/a.html">

Se questo gadget viene selezionato e nessun testo e’ attualmente caricato
nella finestra principale, allora MWM chiedera’ se cio’ non abbia
importanza e, se cosi’ e’, creera’ automaticamente una linea di testo (la
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prima) dove potra’ memorizzare le informazioni del HEAD.

Se si rende necessario ritoccare un oggetto di tipo HEAD, e’ sufficiente
clickare sul gadget "HEAD" quando il suddetto oggetto e’ selezionato.

1.10 MWM.guide/Settimo gadget CENTER

CENTER gadget

Questa azione permette di centrare tutto il testo selezionato <CENTER>.

1.11 "

FONT gadget

Con questa azione si ha a disposizione un modo alternativo per modificare
le dimensioni e il colore del testo, per esempio

<FONT SIZE="+1" COLOR="#00FFFF" Hello world! </FONT>

1.12 "

CUT gadget

La stessa azione dello item "Cut" del menu "Edit".

1.13 "

SEARCH gadget

La stessa azione dello item "Search" del menu "Edit".

1.14 "

EDIT gadget

La stessa azione dello item "Adjust selected lines" del menu "Edit".

1.15 MWM.guide/Ottavo gadget VIEW
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VIEW gadget

Questa azione vi permette di chiamare un programma tipo Mosaic per vedere
in qualunque momento il lavoro finale.
Il programma da chiamare e’ definito usando il gadget
"PREFS" alla voce "Browser"

E’ possibile aprire MWM ed il vostro browser preferito usando lo stesso
schermo pubblico.

1.16 MWM.guide/Nono gadget PREFS

PREFS gadget

Questa azione mostrera’ la seguente lista di possibilita’:

GUI:

- Screen

Si puo’ scegliere se aprire lo schermo pubblico di MWM nei modi:

Default | Named | Owner

Se si sceglie il modo "Default", MWM aprira’ tutte le sue
finestre sullo schermo pubblico di default (Workbench).

Se si sceglie il modo "Named", MWM vi chiedera’ con un
requester il nome dello schermo pubblico su cui aprire le
finestre.

Se si sceglie il modo "Owner", MWM vi chiedera’ con un
requester il tipo di risoluzione del suo schermo personale,
che sara’ ugualmente pubblico ma con l’appropriata palette di
colori.

- Font

Cambia il font nella finestra principale.

Default paths:

- ASCII texts
Per definire un path comune a tutti i testi.

- Images
Per definire un path comune a tutte le immagini.

- Work dir
Per definire la directory di lavoro (ex: RAM:T).

Log window:

- Log Window
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Permette di personalizzare la finestra di aiuto.

- Log Level
MWM mette a disposizione tre livelli di informazioni:

- None, ovvero nulla se non l’essenziale.
- Medium, descrizione sommaria dell’ oggetto selezionato.
- High, informazione dettagliata.

Utils:

- Browser
Per scegliere il programma che dovra’ effettuare il preview.

- Sites list
Per scegliere il file contenente la lista dei siti.

HTML defaults:

- Headings size;
Quando viene caricato un normale file di testo ASCII, MWM
assegna ad ogni linea un valore pari a zero (default)
percui, se c’e’ bisogno di cambiare il valore di default
per gli headings, MWM salvera’ il valore selezionato al
posto di zero.

Per cambiare questo valore standard e’ necessario
scegliere uno fra "H1 H2 H3 H4 H5 H6" nella listview.

- BR as EOL

Se attivo, MWM inserira’ la parola chiave <BR> alla fine di ogni linea
cosi’ il testo verra’ salvato rispettando il piu’ possibile
l’impaginazione mostrata nella finestra principale.

- FONT versus Heading

Il suo scopo e’ quello di prevenire un possibile conflitto tra
FONT e Heading.
Si puo’ scegliere tra queste opzioni:

- Only FONT ; l’ heading verra’ ignorato
- Only heading ; FONT verra’ ignorato
- Mixed (default) ; entrambi verranno scritti

Other

- OK + autosave
Se attivo, MWM salvera’ automaticamente il lavoro nel formato HTML
ogni volta che il gadget "OK" nelle finestre Text, Image, List e Form
verra’ clickato.
Se si sta lavorando con il preview, allora sara’ sufficiente dire al
browser di operare un reload del file automaticamente agiornato da MWM.
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1.17 MWM.guide/La finestra per la singola linea

LA FINESTRA PER LA SINGOLA LINEA.

Selezionando con un doppio click una qualsiasi linea del testo nella finestra
principale, si aprira’ la finestra per la singola linea che permettera’
all’ utente di MWM di editare piu’ in dettaglio il testo.

Qui e’ possibile inserire testi, immagini e input.
Se la linea editata non fa parte di un form, allora solo i gadget TEXT e
IMAGE saranno disponobili all’uso, altrimenti solo il gadget FORM.
Sono disponibili anche in questa finestra i tasti speciali F1, F2 e F4 per
queste tre funzioni.

MWM permette qui di usare entrambi i tasti del mouse (sinistro e destro):

* Tasto sinistro:

- clickando e trascinando il puntatore si seleziona parte della
riga da editare;

- con un doppio click su un oggetto gia’ creato, MWM aprira’ la
finestra corrispondente di quell’oggetto;

* Tasto destro:

- se si clicka in un oggetto gia’ esistente, l’effetto e’ identico
al doppio click del tasto sinistro altrimenti verra’ selezionata
l’intera parola al di sotto del puntatore;

- se si clicka fuori della finestra, la finestra per la singola
linea verra’ automaticamente chiusa (anche con il tasto ESC).

1.18 MWM.guide/La finestra di aiuto

LA FINESTRA DI AIUTO.

Selezionando un oggetto nella finestra principale si notano dei dati che
vengono visualizzati in un’ altra finestra: la finestra di aiuto.

Questa finestra vi dara’ tutte le informazioni contenute negli oggetti:
il numero, il tipo, il path di immagini e testi, le label a cui punta
ed altro ancora.

Il livello di tali informazioni si puo’ definire selezionando il gadget
"PREFS", scegliendo la voce "Log level".

1.19 MWM.guide/La finestra ” What is? ”

LA FINESTRA "What Is ?".

Questa finestra e’ un supplemento alla finestra di aiuto e si trova alla ←↩
immediata
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sinistra della finestra principale.

La funzione di questa finestra e’ essenzialmente quella di dare un immediato ←↩
commento
a tutti gli oggetti creati collaborando con la differenziazione dei colori del
testo per ognuno di essi.

Esempio:

+-----------++----------------------------------+
| What is? || MWM Edit Window |
+-----------++----------------------------------+
| ......... || Uninitialized text |
| txt Hn X || Initialized Text |
| txt->in || Text linked to current document |
| txt->out || Text linked to another document |
| txt->site || Text linked to a site |
| img simple|| Simple image |
| img->in || Image linked to current document |
| img->out || Image linked to another document |
| img->site || Image linked to a site |
| img map || Map image |
| head || Text of the <HEAD> block |
| Form type || Text of the <FORM> block |
| preformat || Preformatted text <PRE> |
| address || Text of the <ADDRESS> block |
| paragraph || Paragraph text <P> |
| Multi obj || Text including more objects |
| Label || There is a label <ID> |
| Comment || There is a comment <!-- ... --> |
| Lab & Com || There is both label and comment |
| break || There is a break <BR> |
| line || There is an horizontal rule <HR> |
| font n || There is a FONT |
| centered || There is a centered text <CENTER>|
+-----------++----------------------------------+

Descrizione:

Hn = Heading da <H1> a <H6>, <HD> per il valore di default.
X = Allineamento: L = LEFT, C = CENTER, R = RIGHT, J = JUSTIFY

type = Form method GET o POST
n = Size of font

Con il tasto del e’ possibile aprire o chiudere questa finestra.

1.20 MWM.guide/Il menu

IL MENU

Nella finestra principale e’ possibile usare un menu con le seguenti voci:

Project Edit Special Action
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Load plain Text

Cut
Insert label

Text

HTML save

Copy
Go to label

Image

HTML save as...

Paste
Mark location 1

List

Load project

Search new
Mark location 2

Form

Save project

Search again
Mark location 3

More

Delete all

Adjust sel lines
Jump to mark 1

Head

Help keys
Jump to mark 2

Center

About
Jump to mark 3

Preview

Quit
Jump to next TEXT

Prefs
Jump to next IMAGE

Jump to next LIST
Jump to next FORM

1.21 MWM.guide/Project->Load text

Delete all
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Cancella tutto il lavoro o solo tutti gli oggetti.
(Usare con cautela!)

1.22 MWM.guide/Project->Load plain text

Load plain text

Permette di caricare un normale file di testo ASCII.

Se un testo e’ gia’ stato caricato, MWM vi chiedera’ se cancellare il
precedente o accodare il nuovo al vecchio.

- Replace
- Insert to the beginning;
- Insert to the end;
- Insert after the first selected line.

1.23 MWM.guide/Project->keys

Tasti speciali

Se il testo e’ piu’ lungo o piu’ largo della capacita’ della finestra, lo si
puo’ scrollare sia con i gadget della finestra, sia con i tasti frecce.

I tasti frecce, da soli, scrollano di una linea o di una colonna. Se
sciftati, scrollano una pagina su / giu’ / destra / sinistra. Premendo il
tasto alt con i tasti frecce il testo si posizionera’ a inizio / fine oppure
tutto a sinistra / destra. Con il tasto control, invece, le frecce
serviranno per dimensionare la finestra principale.

Il tasto help apre o chiude la finestra di Log.

Il tasto del apre o chiude la finestra "What is?".

Il tasto enter permette di editare la prima linea selezionata.

Il tasto return inserisce una linea vuota nel testo.

1.24 MWM.guide/Project->HTML save

HTML save

Salva automaticamente il lavoro nello stesso file HTML oppure, se
non precedentemente definito, questa azione aprira’ la finestra
Save come descritto di seguito.
Se il modo "OK + autosave" delle preferenze e’ attivo, questa
funzione verra’ anche eseguita automaticamente ogni volta che il
gadget "OK" viene selezionato nelle finestre Text, Image, List e
Form.
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1.25 MWM.guide/Project->HTML save as...

HTML save as...

Permette di salvare il lavoro creando il file HTML.

Questa azione aprira’ la finestra Save con questi gadget:

"Background" gadget:

Puo’ essere usato per specificare l’immagine che dovra’
riempire il backround del file HTML.

"BGColor" gadget:

Definisce il colore del background.

"Text" gadget:

Definisce il colore del testo del documento.

"Link" gadget:

Specifies the color used to stroke the text for unvisited
hypertextlinks at the moment the user clicks on the link.

"VLink" gadget:

Specifies the color used to stroke the text for visited
hypertext links.

"ALink" gadget:

Specifies the highlight color used to stroke the text for
hypertext links at the moment the user clicks on the link.

"Save ALL text" gadget:

Tutto il testo presente nella finestra principale deve essere
salvato nel file HTML.

"Save only INITIALIZED text" gadget:

Solo gli oggetti creati nella finestra principale dovranno
essere salvati, tutto il resto verra’ ignorato.

"Cancel" gadget:

Ritorna senza nulla di fatto alla finestra principale.

1.26 MWM.guide/Project->Load project

Load project
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Carica un lavoro precedentemente salvato.

1.27 MWM.guide/Project->Save project

Save project

Salva l’ intero lavoro in un file in modo da poterlo richiamare e ←↩
continuare

a lavorare dal punto in cui lo si era lasciato.

1.28 MWM.guide/Project->About

About

Informazioni riguardanti l’ ideatore ed il creatore di MWM.

1.29 MWM.guide/Project->Quit

Quit

Fine del lavoro.
MWM salvera’ le preferences e la posizione/dimensione della
finestra principale nel file "MWM.prefs" in ENV: ed in ENVARC:.

1.30 MWM.guide/Edit->Cut

Cut

Questa azione permette di eliminare completamente le linee selezionate
oppure solamente le informazioni create per esse.
Se le si eliminano completamente, allora il testo cancellato verra’
copiato in clipboard.

1.31 MWM.guide/Edit->Copy

Copy

Questa azione copia le linee selezionate in clipboard.
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1.32 MWM.guide/Edit->Paste

Paste

per inserire il testo contenuto nella clipboard a partire dalla
prima linea selezionata.

Se state usando (per esempio) KCON: per la finestra di log,
potete scrivere cio’ che volete in questa finestra, selezionare
tutto il testo con il mouse e premere "Amiga+C" per copiare il
tutto in clipboard.
RICORDATE: premete return dopo l’ ultima riga altrimenti la

console rimarra’ occupata e MWM non potra’ mandare
messaggi.

Dopo, selezionate la finestra principale di MWM e premete
"Amiga+V".

Questo funzionera’ anche con le commodities ConClip e ConPaste.

1.33 MWM.guide/Edit->Search new

Search new

Cerca una nuova stringa nel testo.

1.34 MWM.guide/Edit->Search again

Search again

Cerca la stessa stringa nel testo.

1.35 MWM.guide/Edit->Adjust selected lines

Edit selected lines

Questa azione permette di editare tutte le linee selezionate.
Se la linea selezionata non e’ un multi object, non verranno modificati
in alcun modo gli oggetti creati precedentemente.
Altrimenti, se c’e’ realmente il bisogno di modificarla, tutti gli
oggetti in essa contenuti dovranno essere cancellati.

1.36 MWM.guide/Cosa puo’ fare MWM ?

COSA PUO’ FARE MWM ?

MWM e’ in grado di gestire le seguenti cose:
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- HEAD LINK REL=Banner
META NAME="generator/description/author" CONTENT="..."

- TITLE
- BODY BACKGROUND="..." BGCOLOR="#color" TEXT="#color"

LINK="#color" VLINK="#color" ALINK="#color"
- ADDRESS
- CENTER
- FONT SIZE="n" COLOR="#color"
- A HREF="...#..."
- A ID="..."
- IMG ISMAP ALIGN=TOP|MIDDLE|BOTTOM SRC="..." ALT="..."
- UL TYPE="disc|circle|square" COMPACT PLAIN LH LI
- OL TYPE="A|a|I|i|1" COMPACT CONTINUE SEQNUM=n LH LI
- DL COMPACT LH DT DD
- <!-- comment -->
- BR
- HR
- P ALIGN=LEFT|CENTER|RIGHT|JUSTIFY
- CITE
- CODE
- EM
- STRONG
- AUTHOR
- PERSON
- SAMP
- KBD
- VAR
- DFN
- Q
- ACRONYM
- ABBREV
- INS
- DEL
- B
- I
- TT
- U
- S
- BIG
- SMALL
- SUB
- SUP
- &lt; &gt; &amp; &quot;

&Aacute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;

- URL for the links
- FORM METHOD=GET|POST
- INPUT TYPE=TEXT|PASSWORD|CHECKBOX|RADIO|RANGE|SCRIBBLE|FILE|HIDDEN|

SUBMIT|IMAGE|RESET
TEXTAREA
NAME,VALUE,SIZE,MAXLENGTH,CHECKED,MIN,MAX,SRC,ACCEPT
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- List of INPUTs
- Headings: <H1|H2|H3|H4|H5|H6 ALIGN=LEFT|CENTER|RIGHT|JUSTIFY>

1.37 MWM.guide/Informazioni generali

INFORMAZIONI GENERALI

Questo programma e’ stato studiato seguendo il piu’ possibile le
specifiche della documentazione di Wilbur HTML 3.2.

MWM richiede un sistema operativo dal 3.0 in poi.

MWM lavora con le librerie gadtools e reqtools.

Questa versione e’ assolutamente Copyright ©1996-97 Massimo Baglione.

Se ti piace questo programma e hai bisogno di tutte le funzioni
disabilitate, puoi spedirmi 40.000 lire italiane al seguente indirizzo:

Massimo Baglione
Via Della Chiesa 1
67019 Civitatomassa
Scoppito L’ AQUILA (Italy)

specificando dove posso mandare il programma completamente funzionante.

Per qualunque consiglio, critica o idea riguardo MWM, contattate subito:

Massimo Baglione Maurizio Fabiani
(MAUI for Amiga BBS)

39:102/1.5 AmigaNet 39:102/1
39:102/2.5 39:102/2

2:335/602.5 FidoNet 2:335/602
2:335/607.5 2:335/607

InterNet

(Maurizio Fabiani) maui@mbox.vol.it

1.38 MWM.guide/Ringraziamenti

RINGRAZIAMENTI

Devo ringraziare tutti i miei betatester per il loro ottimo bug report
riguardo MWM. In particolare, voglio citare:

Troy Bouchard, Mel Greer, Alessandro Di Michele, Kirk Strauser,
Girish V Nath, Paul Stevens.

e, per tutto cio’ che riguarda il resto dello sviluppo di MWM:
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Jeff Lavin per il suo grande aiuto riguardo il doc inglese!
David Putzier per il suo fantastico MWMlogo.iff ...check it Out!
Pierluigi Sferrella per il manuale italiano in formato amigaguide.
Mike Handley per il manuale inglese in formato amigaguide.
Wolfgang G. Wettach per il manuale in tedesco.

Poi, un grande bacio (!) lo mando al mio Boss (Maurizio Fabiani) per la
sua infinita pazienza!

L’ ultimo ringraziamento e’ riservato ad Amiga:
(tutti insieme) ...GRAZIE AMIGA!

-----+-----

-=> * \X/ Amiga! \X/ MAUI BBS! \X/ Love and Beer! * <=-

_The revenge of the italian products_

...enjoy this program!!!

1.39 MWM.guide/Storia di MWM

Novita’ implementate in questa ultima versione di MWM:

-MWM v. 3.11 Mar 12 1997

- Adjusted a little conflict between FONT and Headings.
- Added "FONT versus Heading" gadget in Prefs window.

This gadget lets you choose if you need to write only FONT, only Headings
or both (default).

- Some internal optimizations.

-MWM v. 3.10 Feb 24 1997

- Little adjustements.

-MWM v. 3.00 Feb 19 1997

- Updated to Wilbur - HTML 3.2.
- MWM 3.00 will only load the old projects done by MWM 2.12;

previous versions may cause problems!
To update your projects (starting with "WORK_MWM_NEW_4") just load and
resave with MWM 3.00.

- Added "Jump to next TEXT/IMAGE/LIST/FORM" items to "Special" menu.
These actions will start a search for the specific object starting from
the next line after the last selected line. (Useful, I think !).

- Added "author" for META.
- Added "Bullet/Number" gadget in List window.

This action allows you to specify the bullet type (disc, circle, square)
for UL or the numbering method (arabic, alphanumeric, roman) for OL.

- Updated OL’s attribute SEQNUM to START.
- Changed "Choose" gadget type into "IMAGE window" from text to string.
- Changed "Font" text on "TEXT window" to "Heading".
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- Added FONT tool gadget into "Main window".
With this feature you have an alternative way to modify the text size
and the respective color, for example:

<FONT SIZE="+1" COLOR="#00FFFF" Hello world! </FONT>
If possible, the "What is?" window will show a little information
where the FONT was inserted.

- Added CUT, SEARCH and EDIT tool gadgets into "Main window".
- Added "Insert label" item to "Special" menu.
- Improved gui for "Load text" if another text was loaded.

1.40 MWM.guide/Addendum

Ciao!

1>
Un appunto per il manuale in tedesco tradotto da Wolfgang G. Wettach:

probabilmente il suo lavoro non verra’ agiornato dal sottoscritto
ogni volta che uscira’ una nuova versione di MWM, quindi il
manuale in tedesco e’ valido solo per la versione 2.00.

2>
Provate a caricare il file "MWM_eng_HTML.project" incluso in questo
archivio!

E’ il progetto della versione HTML del manuale in inglese.
L’ho incluso per i nuovi utenti di MWM che non hanno le idee chiare
sul funzionamento del programma.

Grazie di usare MWM!


	MWM
	MWM.guide/Contenuti
	MWM.guide/Di cosa si tratta?
	MWM.guide/La finestra principale
	MWM.guide/Primo gadget TEXT
	MWM.guide/Secondo gadget IMAGE
	MWM.guide/Terzo gadget LIST
	MWM.guide/Quarto gadget FORM
	MWM.guide/Quinto gadget MORE
	MWM.guide/Sesto gadget HEAD
	MWM.guide/Settimo gadget CENTER
	"
	"
	"
	"
	MWM.guide/Ottavo gadget VIEW
	MWM.guide/Nono gadget PREFS
	MWM.guide/La finestra per la singola linea
	MWM.guide/La finestra di aiuto
	MWM.guide/La finestra '' What is? ''
	MWM.guide/Il menu
	MWM.guide/Project->Load text
	MWM.guide/Project->Load plain text
	MWM.guide/Project->keys
	MWM.guide/Project->HTML save
	MWM.guide/Project->HTML save as...
	MWM.guide/Project->Load project
	MWM.guide/Project->Save project
	MWM.guide/Project->About
	MWM.guide/Project->Quit
	MWM.guide/Edit->Cut
	MWM.guide/Edit->Copy
	MWM.guide/Edit->Paste
	MWM.guide/Edit->Search new
	MWM.guide/Edit->Search again
	MWM.guide/Edit->Adjust selected lines
	MWM.guide/Cosa puo' fare MWM ?
	MWM.guide/Informazioni generali
	MWM.guide/Ringraziamenti
	MWM.guide/Storia di MWM
	MWM.guide/Addendum


